学习啦 > 学习电脑 > 操作系统 > Linux教程 > CentOS系统中怎么安装搭建

CentOS系统中怎么安装搭建

时间: 春健736由 分享

CentOS系统中怎么安装搭建

  PN网关通过对数据包的加密和数据包目标地址的转换实现远程访问。有多种分类方式,主要是按协议进行分类。可通过服务器、硬件、软件等多种方式实现。那么CentOS系统中怎么安装搭建?下面跟着学习啦小编一起去了解下吧。

  CentOS系统怎么安装搭建

  【安装】(本次教程架设在之前免费申请的一个月Xen V*P*S 256MB上,系统为centos5/32位,PPTP 一键安装包对系统要求为centos5 32 /64)

  首先,我们putty用root密码登录,键入下面的指令:

  wget http://d.xker.com/2014/pptpd.sh

  (这一步是下载安装脚本,备选下载链接:http://www.zrblog.net/sh/pptpd.sh)

  下载安装脚本之后,安装就可以了,一键安装,不用输入什么,非常方便。

  sh pptpd.sh

  附图:

  安装完成后,大家要注意,最后一行是你的用户,密码,要记住。如果你需要添加用户,只要直接编辑/etc/ppp/chap-secrets文件,按照相同格式添加用户名和密码即可。

  【后记】

  OpenVZ用户请先检查

  虚拟网卡(TUN/TAP)支持(代码如下)

  cat /dev/net/tun

  如果返回信息为:

  cat: /dev/net/tun: File descriptor in bad state 说明正常

  检测是支持ppp模块

  cat /dev/ppp

  如果返回信息为:cat: /dev/ppp: No such device or address 说明正常

  【后续】

  有些OpenVZ,直接安装了一键包之后,仍然不能使用。这里,我补充几点。

  1.首先,我们确认VPS已经开启了TUN和PPP,关于确认的方法,上面已经给出;

  2.安装好一键包之后,可以编辑链接的用户信息(vim /etc/ppp/chap-secrets);

  3.去加密。编辑/etc/ppp/options.pptpd(vim /etc/ppp/options.pptpd),在require-mppe-128前面加个#(# require-mppe-128);

  4.本地设置加密方式为可选加密,并允许未加密的密码。

  5.最后重启下PPTPD:/etc/init.d/pptpd restart

  6.有朋友遇到安装报错的问题(内容大约为etc/ppp文件夹找不到),并提出解决方案,有类似情况的朋友可参考之:

  编辑 /etc/yum/pluginconf.d/fastestmirror.conf 将enabled=1修改为enabled=0

  上面就是CentOS安装搭建的方法介绍了,需要注意的是,该方法只适用于CentOS,至于其他的Linux系统可作为参考,你记住了吗?

看过“ CentOS系统中怎么安装搭建 ”的人还看了:

1.如何在CentOS系统中安装搭建

2.Linux配置minicom的步骤有哪些

3.it个人简历范文3篇

4.Linux Bonding配置方法有哪些

5.软路由怎么搭建服务器

精彩文章

    IIS 10.0 详细错误 - 500.0 - Internal Server Error

    HTTP 错误 500.0 - Internal Server Error

    FastCGI 进程最近常常失败。请过一会再尝试此请求

    最可能的原因:

    • IIS 收到了请求;但在处理请求过程中出现内部错误。此错误的根本原因取决于处理该请求的是哪一个模块以及出现此错误时工作进程中出现了何种情况。
    • IIS 无法访问网站或应用程序的 web.config 文件。如果 NTFS 权限设置不正确,便会出现这种情况。
    • IIS 无法处理网站或应用程序的配置。
    • 已经过身份验证的用户没有使用此 DLL 的权限。
    • 该请求将被映射到托管处理程序,但不会安装 .NET 可扩展功能。

    可尝试的操作:

    • 确保 web.config 文件的 NTFS 权限正确,并允许访问 Web 服务器的计算机帐户。
    • 检查事件日志中是否记录了任何附加信息。
    • 确认 DLL 的权限。
    • 如果请求被映射到托管处理程序,则安装 .NET 可扩展功能。
    • 创建跟踪规则以跟踪此 HTTP 状态代码的失败的请求。有关为失败的请求创建跟踪规则的详细信息,请单击此处。

    详细错误信息:

    模块   FastCgiModule
    通知   ExecuteRequestHandler
    处理程序   php-8.2.12
    错误代码   0x80004005
    请求的 URL   http://xiaobai.credit189.com:80/linappauto/seo_art_list.php
    物理路径   D:\Web\credit189xiaobai\linappauto\seo_art_list.php
    登录方法   匿名
    登录用户   匿名

    详细信息:

    此错误表明在处理请求时出现问题。Web 服务器收到了请求,但在处理过程中出现错误,导致 500 错误。

    查看详细信息 »

    Microsoft 知识库文章:

    • 294807
653815