学习啦 > 学习电脑 > 操作系统 > Linux教程 > Linux更改22端口的方法汇总

Linux更改22端口的方法汇总

时间: 孙胜652由 分享

Linux更改22端口的方法汇总

  所谓的22端口就是我们常说的ssh端口,当你在操作Linux过程中,如果遇到网络无法连接的问题,那么可能就是22端口出现了问题,下面学习啦小编就给大家介绍下Linux修复22端口的方法。

  第一种22端口修改方法:

  01假如要改SSH的默认端口(22),那么你只要修改:/etc/ssh/sshd_config中Port 22,这里把22改成自己要设的端口就行了,不过千万别设和现已有的端口相同哦,以防造成未知后果。

  02假如要限制SSH登陆的IP,那么可以如下做:

  先:修改/etc/hosts.deny,在其中加入sshd:ALL

  然后:修改:/etc/hosts.allow,在其中进行如下设置:sshd:192.168.0.241

  这样就可以限制只有192.168.0.241的IP通过SSH登陆上LINUX机器了。当然在做为服务器方面,我都不装gnome和KDE的,而且很多东东都不装,这样增加安全系数。

  第二种22端口修改方法:

  首先修改配置文件

  vi /etc/ssh/sshd_config

  找到#Port 22一段,这里是标识默认使用22端口,修改为如下:

  Port 22 Port 50000 然后保存退出

  执行/etc/init.d/sshd restart

  这样SSH端口将同时工作与22和50000上。

  现在编辑防火墙配置:vi /etc/sysconfig/iptables

  启用50000端口。

  执行/etc/init.d/iptables restart

  现在请使用ssh工具连接50000端口,来测试是否成功。如果连接成功了,则再次编辑sshd_config的设置,将里边的Port22删除,即可。

  之所以先设置成两个端口,测试成功后再关闭一个端口,是为了方式在修改conf的过程中,万一出现掉线、断网、误操作等未知情况时候,还能通过另外一个端口连接上去调试以免发生连接不上必须派人去机房,导致问题更加复杂麻烦。

  上面就是Linux修复22端口的方法介绍了,本文介绍了2种修改22端口的方法,如果你修改22端口后还是无法解决问题,那么就不是22端口的问题了。

精彩文章

    IIS 10.0 详细错误 - 500.0 - Internal Server Error

    HTTP 错误 500.0 - Internal Server Error

    FastCGI 进程最近常常失败。请过一会再尝试此请求

    最可能的原因:

    • IIS 收到了请求;但在处理请求过程中出现内部错误。此错误的根本原因取决于处理该请求的是哪一个模块以及出现此错误时工作进程中出现了何种情况。
    • IIS 无法访问网站或应用程序的 web.config 文件。如果 NTFS 权限设置不正确,便会出现这种情况。
    • IIS 无法处理网站或应用程序的配置。
    • 已经过身份验证的用户没有使用此 DLL 的权限。
    • 该请求将被映射到托管处理程序,但不会安装 .NET 可扩展功能。

    可尝试的操作:

    • 确保 web.config 文件的 NTFS 权限正确,并允许访问 Web 服务器的计算机帐户。
    • 检查事件日志中是否记录了任何附加信息。
    • 确认 DLL 的权限。
    • 如果请求被映射到托管处理程序,则安装 .NET 可扩展功能。
    • 创建跟踪规则以跟踪此 HTTP 状态代码的失败的请求。有关为失败的请求创建跟踪规则的详细信息,请单击此处。

    详细错误信息:

    模块   FastCgiModule
    通知   ExecuteRequestHandler
    处理程序   php-8.2.12
    错误代码   0x80004005
    请求的 URL   http://xiaobai.credit189.com:80/linappauto/seo_art_list.php
    物理路径   D:\Web\credit189xiaobai\linappauto\seo_art_list.php
    登录方法   匿名
    登录用户   匿名

    详细信息:

    此错误表明在处理请求时出现问题。Web 服务器收到了请求,但在处理过程中出现错误,导致 500 错误。

    查看详细信息 »

    Microsoft 知识库文章:

    • 294807
317751